HOME / XPERT ZONE / MikroTik / WAN : 2 WAN (2 Static) to LAN)

WAN : 2 WAN (2 Static) to LAN)

ปรับปรุงข้อมูลล่าสุด : 20170522-005536

UBiQUiTi MikroTik Cisco โดย ซิสทูยู ออนไลน์ | เราคือผู้เชี่ยวชาญระบบไร้สาย www.sys2u.online Line ID : @sys2u





คำถาม



ต้องการคอนฟิก Mikrotik เพื่อทำ Loadbalance รวมเน็ต ทั้ง 2 WAN
Port1 - wan ( Fix IP : Static ) (ทดสอบเน็ตเข้ามา 10m)
Port2 - wan ( Fix IP : Static ) (ทดสอบเน็ตเข้ามา 10m)
Port5 - Lan (IP : 192.168.10.1/24 , dhcp 100-200)

คำตอบ



1. Remove Default Configuration / Reset clear config



1.1 - ติดตั้งโปรแกรม Winbox เรียบร้อยแล้ว

1.2 เข้าโปรแกรม Winbox
- โดยปกติ mikrotik บางรุ่นจะมี default Config มาให้ ซึ่ง IP จะเป็น 192.168.88.1 (ถ้าไม่มีคอนฟิกใดๆจะเป็น 0.0.0.0)
- คลิกเลือกตัวอุปกรณ์ใน list




- เราจะไม่ใช้ default config ให้เลือก Remove Configuration




- หรือทำการ Reset ทั้งหมด โดย
เมนู System > Reset Configuration (เลือก No default Configuration)




กด Yes
(Mikrotik จะรีเซตและ รีบูทตัวเอง 1 รอบ)





1.3 เข้าโปรแกรม Winbox ใหม่อีกรอบ (สังเกตุ IP จะเป็น 0.0.0.0 แสดงว่ารีเซตเรียบร้อย)




2. WAN - Static IP



2.1 ทำการสร้าง IP Address ให้ (wan1)
เมนู IP > Address กด " + " เพื่อ Static IP
- Address: ใส่ IP: 10.1.10.254/24 กด OK (ใน Network จะสร้างให้อัตโนมัติตามวงที่กำหนด /24)
- เลือก ether1




2.2 ทำการสร้าง IP Address ให้ (wan2)
เมนู IP > Address กด " + " เพื่อ Static IP
- Address: ใส่ IP: 10.2.20.254/24 กด OK (ใน Network จะสร้างให้อัตโนมัติตามวงที่กำหนด /24)
- เลือก ether2




2.3 สร้าง Route (WAN1)
- เมนู IP > Route > Routes กดปุ่ม " + "
- Gateway : 10.1.10.1 (ใส่ IP Gateway ของ WAN1)
Check Gateway: ping




- เพิ่มใหม่อีกครั้ง
- Gateway : 10.1.10.1 (ใส่ IP Gateway ของ WAN1)
Check Gateway: ping
Routing mark: wan_1




2.4 สร้าง Route (WAN2)
- เมนู IP > Route > Routes กดปุ่ม " + "
- Gateway : 10.2.20.1 (ใส่ IP Gateway ของ WAN2)
Check Gateway: ping




- เพิ่มใหม่อีกครั้ง
- Gateway : 10.2.20.1 (ใส่ IP Gateway ของ WAN2)
Check Gateway: ping
Routing mark: wan_2




2.5 แสดง Route ที่สร้างเสร็จแล้วของทั้ง 2 WAN




2.6 คัดลอกโค้ด

/ip firewall mangle
add action=mark-routing chain=prerouting dst-address-type=!local new-routing-mark=wan_1 passthrough=no per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-routing chain=prerouting dst-address-type=!local new-routing-mark=wan_2 passthrough=no per-connection-classifier=both-addresses-and-ports:2/1

/ip firewall nat
add action=masquerade chain=srcnat dst-address-type=!local out-interface=ether1
add action=masquerade chain=srcnat dst-address-type=!local out-interface=ether2




2.7 เมนู Terminal > ทำการ วางโค้ดที่คัดลอกก่อนหน้า




3. สร้าง Bridge เพื่อสะดวกต่อการแก้ไขหรือเปลี่ยน Interface พร้อมกำหนด DNS ให้ตัวอุปกรณ์



3.1 เมนู Bridge แท็ป Bridge กด " + "
- ตั้งชื่อ bridge-lan กด OK





- เลือก Interface ที่ต้องการ ให้เข้ามาอยู่ในกลุ่ม Bridge ที่สร้างไว้แล้ว "bridge-lan"
ตัวอย่าง เลือก port5 เข้ามาให้ก่อน (สามารถเพิ่มหรือเปลี่ยนเป็น interface อื่นๆได้)




3.2 ใส่ DNS Server
-ปกติ Mikrotik จะ dynamic ดึง ip มาให้อัตโนมัติให้อยู่แล้ว แต่ก็สามารถกำหนดเพิ่มเองได้
ตัวอย่างใส่เป็น IP ของ google (8.8.8.8, 8.8.4.4)
-ติ๊กเลือก Allow Remote Requests




4. LAN - (สร้าง Network โดยกำหนด IP : 192.168.10.1/24 , dhcp 100-200)



(Hotspot Setup จะมีการสร้าง NAT, Route, IP, DHCP, Pool ฯลฯ ให้อัตโนมัติ ซึ่งสะดวกและรวดเร็วกว่าการ add เองมาก
หากเราไม่ต้องการ hotspot เราก็เพียง disable หรือลบ hotspot ออกทีหลังได้ โดยค่า config ออกเน็ตอื่นๆ ก็ยังอยู่เหมือนเดิม ใช้งานออกเน็ตได้ปกติ)

4.1 สร้าง Hotspot Setup
- เมูน IP > Hotspot
-แท็ป Server กดปุ่ม Hotspot Setup แล้วเลือก Interface "bridge-lan" กด Next




- กำหนด IP Network กด Next
(ตัวอย่างเป็น วง 192.168.10.1 sub 255.255.255.0)




- กำหนด rank DHCP ที่แจ้ง กด Next
(ตัวอย่าง แจก 192.168.10.100 - 200)




- Certificate เลือก none กด Next
(ถ้ามีการติดตั้ง Certificate จะทำให้ hotspot รองรับ login ผ่าน https:// ได้ และจะมี List ขึ้นมาให้เลือก)




- กด Next




- DNS Server จะขึ้นให้อัตโนมัติ กด Next




- DNS Name (ปล่อยว่าง) กด Next
(ปกติ hotspot จะแสดงเป็น IP แต่ถ้ากำหนดชื่อในส่วนนี้ ก็จะเป็น NAME แทน)




- Local user hotspot ใช้ default กด Next
(เป็น user ที่ใช้ login เข้า hotspot ปกติจะเป็น admin ไม่มีพาส)




- สร้าง hotspot เสร็จสิ้น กด OK




4.2 ทำการ disable Hotspot ที่สร้าง เพื่อให้ใช้งาน เชื่อมต่อ lan ได้ปกติไม่ต้องมี login hotspot




- หลังจาก diable แล้ว ก็จะขึ้นเป็นสีเทาๆ




TIP : สามารถสร้างบริดจ์อื่นเพิ่ม เช่น
- bridge-lan สำหรับ network ที่เข้าใช้งานเน็ตได้เลยไม่ต้อง login
- bridge-hotspot สำหรับทำ hotspot กำหนดให้ผู้ใช้มีการ login user,pass ก่อนออกเน็ต
โดยสร้างกำหนด limit bandwidth ของแต่ละ user ได้ด้วย
แล้วจึงเลือก Interface ที่ต้องการ ว่าจะให้ port ไหนเป็นอะไรทีหลัง

5. Speed Test - Loadbalance


Wan1 (10m) + Wan2 (10m) = Speed รวมได้ 20m





จบบทความ

Back to XPERT ZONE

UBiQUiTi MikroTik Cisco โดย ซิสทูยู ออนไลน์ | เราคือผู้เชี่ยวชาญระบบไร้สาย www.sys2u.online Line ID : @sys2u

02-183-6101-2
Line ID : @sys2u
infosys2u.com

บริษัท เบซิสแวร์ ซิสเต็มส์ จำกัด
5/27 ซอยอนามัย ถนนศรีนครินทร์
เขต/แขวงสวนหลวง กรุงเทพมหานคร 10250

ทะเบียนการค้าเลขที่ 0105545078818
เลขประจำตัวผู้เสียภาษี 0105545078818

โทรศัพท์ 02-183-6101-2
โทรสาร/แฟกส์ 02-721-3042
สายด่วน 086-378-2262

อ่อนนุช 39 หรือ ศรีนครินทร์ 24

แผนที่ Google Map

ออนไลน์วันที่ 19 ตุลาคม พ.ศ. 2550
11 ปี 10 เดือน 5 วัน 23 ชั่วโมง 34 นาที

© 2019 | SYS2U ONLINE