HOME / XPERT ZONE / MikroTik / คู่มือการบล็อค BitTorrent ด้วยอุปกรณ์ MikroTik

คู่มือการบล็อค BitTorrent ด้วยอุปกรณ์ MikroTik

ปรับปรุงข้อมูลล่าสุด : 20170502-225312






คู่มือการบล็อค BitTorrent ด้วยอุปกรณ์ MikroTik

คำถาม


อยากทราบวิธีการ Block BitTorrent ด้วย MikroTik จะต้องตั้งค่าอย่างไรบ้าง ?

คำตอบ




Before - ทดสอบโหลดบิท Torrent

โหลดบิทได้เต็มสปีดเน็ต




ทำการ block โดยก็อป Code ใส่ใน Terminal

1. ดาวน์โหลด ไฟล์ Code
- 2560-05-01-block-bit

2. กดปุ่ม Control+A เพื่อทำการ copy ทั้งหมด






/ip firewall layer7-protocol
add comment="P2P WWW web base cnoetent Matching / Sys2u.online" name=p2p_www regexp=\
"^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirate|commonbits).*\$"
add comment="P2P DNS Matching / Sys2u.online" name=p2p_dns regexp=\
"^.+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy|gpirate|commonbits).*\$"

/ip firewall mangle
add action=mark-packet chain=postrouting comment="p2p download" disabled=no layer7-protocol=p2p_www new-packet-mark="p2p download" passthrough=no
add action=mark-packet chain=postrouting disabled=no layer7-protocol=p2p_dns new-packet-mark="p2p download" passthrough=no

/ip firewall filter
add action=drop chain=forward comment="Block P2p_www Packets / Sys2u.online" disabled=no layer7-protocol=p2p_www
add action=drop chain=forward comment="Block P2p_dns Packets / Sys2u.online" disabled=no layer7-protocol=p2p_dns
add action=drop chain=forward comment="TORRENT No 1: Classic non security torrent" disabled=no p2p=all-p2p
add action=drop chain=forward comment="TORRENT No 2: block outgoing DHT" content=d1:ad2:id20: disabled=no dst-port=1025-65535 packet-size=95-190 protocol=udp
add action=drop chain=forward comment="TORRENT No 3: block outgoing TCP announce" content="info_hash=" disabled=no dst-port=2710,80 protocol=tcp
add action=drop chain=forward comment="TORRENT No 4: prohibits download .torrent files. " content="\r\nContent-Type: application/x-bittorrent" disabled=no protocol=tcp src-port=80
add action=drop chain=forward comment="TORRENT No 5: 6771 block Local Broadcast" content="\r\nInfohash:" disabled=no dst-port=6771 protocol=udp









3. เข้า Winbox
เมนู terminal คลิกขวา เพื่อ Paste




หน้าจอแสดง Code เรียบร้อย




4. ตรวจสอบ Firewall ว่ามีการติดตั้งเรียบร้อย
เมนู IP > Firewall แท็ป Filter Rules

- ทดสอบบน Mikrotik RouterOS v.6.38.3 (filter rule ปกติ)




- ทดสอบบน Mikrotik RouterOS v.6.39
* ( เนื่องด้วย version 6.39 มีการปิด p2p ของ filter rule ทำให้โค้ดที่ป้อนเป็นสีแดง ไม่เป็นไร block ได้อยู่ )




เมนู IP > Firewall แท็ป Mangle




เมนู IP > Firewall แท็ป Layer 7 Protocols




After - ทดสอบโหลดบิท Torrent

* ตอนทดสอบ ควรปิดและเปิดโหลดใหม่ (เนื่องด้วย connection เดิมที่เชื่อมอยู่ จะไม่ถูกตัดน่ะครับ)

โหลดไม่ขึ้น นิ่งสนิท แต่ออกเน็ตใช้งานอื่นๆได้ปกติ





จบบทความ

Back to XPERT ZONE

02-183-6101-2
Line ID : @sys2u
infosys2u.com

บริษัท เบซิสแวร์ ซิสเต็มส์ จำกัด
5/27 ซอยอนามัย ถนนศรีนครินทร์
เขต/แขวงสวนหลวง กรุงเทพมหานคร 10250

ทะเบียนการค้าเลขที่ 0105545078818
เลขประจำตัวผู้เสียภาษี 0105545078818

โทรศัพท์ 02-183-6101-2
โทรสาร/แฟกส์ 02-721-3042
สายด่วน 086-378-2262

อ่อนนุช 39 หรือ ศรีนครินทร์ 24

แผนที่ Google Map

ออนไลน์วันที่ 19 ตุลาคม พ.ศ. 2550
10 ปี 9 เดือน 3 วัน 4 ชั่วโมง 12 นาที

© 2018 | SYS2U ONLINE